# CVE-2022-41131: Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection)

> Attackers can execute arbitrary OS commands in the task execution context via the Hive Provider connection, requiring an upgrade to the provider.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** BIT-airflow-2022-41131, GHSA-cm43-f2pv-6v68, PYSEC-2026-772

## What is CVE-2022-41131?

CVE-2022-41131 is a high-severity command injection vulnerability in Apache Airflow, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-41131?

4 open source packages ship an affected version, including apache-airflow-providers-apache-hive and airflow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 4.1.0 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 4.1.0 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 4.1.0 |
| `airflow` | Bitnami | All versions | 2.3.0 |

Products: Apache Airflow, Apache Apache-Airflow-Providers-Apache-Hive.

## How do I fix CVE-2022-41131?

Upgrade apache-airflow-providers-apache-hive to 4.1.0 or later.

## Is CVE-2022-41131 being exploited?

There is no known exploitation of CVE-2022-41131 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41131 and fix it if it is affected.

What it is: CVE-2022-41131 is a high-severity command injection vulnerability in Apache Airflow, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41131 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0
- airflow (Bitnami): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41131/ (Markdown: https://insights.sbomify.com/CVE-2022-41131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41131
- OSV: https://osv.dev/vulnerability/CVE-2022-41131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41131/
Summaries are generated and may contain mistakes; the official description above is the record.
