# CVE-2022-4122: Buildah (as part of Podman) vulnerable to Link Following

> Attackers can read arbitrary files via symlink traversal in ignore files, exposing sensitive data to unauthorized users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** AZL-44526, DEBIAN-CVE-2022-4122, GHSA-4crw-w8pw-2hmf, GO-2022-1151, UBUNTU-CVE-2022-4122

## What is CVE-2022-4122?

CVE-2022-4122 is a medium-severity path traversal vulnerability in Fedoraproject Fedora, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in buildah. Incorrect following of symlinks while reading .containerignore and .dockerignore results in information disclosure.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2022-4122?

6 open source packages ship an affected version, including github.com/containers/podman/v4, github.com/containers/podman and github.com/containers/podman/v2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v4` | Go | All versions | 4.5.0 |
| `github.com/containers/podman/v4` | Go | All versions | 4.5.0 |
| `github.com/containers/podman/v4` | Go | All versions | 4.5.0 |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |

Products: Fedoraproject Fedora, Podman Project Podman.

## How do I fix CVE-2022-4122?

Upgrade github.com/containers/podman/v4 to 4.5.0 or later.

## Is CVE-2022-4122 being exploited?

There is no known exploitation of CVE-2022-4122 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4122 and fix it if it is affected.

What it is: CVE-2022-4122 is a medium-severity path traversal vulnerability in Fedoraproject Fedora, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4122 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.5.0
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.5.0
- github.com/containers/podman/v4 (Go): affected all versions; fixed in 4.5.0
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4122/ (Markdown: https://insights.sbomify.com/CVE-2022-4122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4122
- OSV: https://osv.dev/vulnerability/CVE-2022-4122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4122/
Summaries are generated and may contain mistakes; the official description above is the record.
