{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:anchore-container-scanner. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41225 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:anchore-container-scanner to 1.0.25 or later.","what":"CVE-2022-41225 is a medium-severity cross-site scripting vulnerability in Jenkins Anchore Container Image Scanner Plugin, published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-41225 and fix it if it is affected.\n\nWhat it is: CVE-2022-41225 is a medium-severity cross-site scripting vulnerability in Jenkins Anchore Container Image Scanner Plugin, published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-41225 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:anchore-container-scanner (Maven): affected all versions; fixed in 1.0.25\n- org.jenkins-ci.plugins:anchore-container-scanner (Maven): affected all versions; fixed in 1.0.25\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41225/ (Markdown: https://insights.sbomify.com/CVE-2022-41225/index.md)","id":"CVE-2022-41225","markdown":"https://insights.sbomify.com/CVE-2022-41225/index.md","name":"CVE-2022-41225","record":{"aliases":["GHSA-f2j5-w76m-3rqh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Anchore plugin allows attackers controlling API responses to execute scripts in user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"anchore_container_image_scanner","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control API responses by Anchore engine.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Anchore Container Image Scanner Plugin vulnerable to cross site scripting","id":"CVE-2022-41225","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Compuware Common Configuration Plugin vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2022-41226"},"packages":[{"ecosystem":"Maven","fixed":["1.0.25"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:anchore-container-scanner","purl":null,"source":"GHSA-f2j5-w76m-3rqh"},{"ecosystem":"Maven","fixed":["1.0.25"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:anchore-container-scanner","purl":"pkg:maven/org.jenkins-ci.plugins/anchore-container-scanner","source":"GHSA-f2j5-w76m-3rqh"}],"prev":{"headline":"Jenkins vulnerable to stored cross site scripting in the I:helpIcon component","id":"CVE-2022-41224"},"products":["Jenkins Anchore Container Image Scanner Plugin"],"published":"2022-09-21","related":[{"cvss_score":6.5,"headline":"Jenkins Anchore Container Scanner Plugin vulnerable to Insufficiently Protected Credentials","id":"CVE-2019-16542","kev_date_added":null,"published":"2019-11-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Anchore plugin allows attackers controlling API responses to execute scripts in user sessions.","url":"https://insights.sbomify.com/CVE-2022-41225/"}