{"answers":{"affected":"2 open source packages ship an affected version, including com.compuware.jenkins:compuware-common-configuration. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41226 in the wild and no public exploit code.","fix":"Upgrade com.compuware.jenkins:compuware-common-configuration to 1.0.15 or later.","what":"CVE-2022-41226 is a critical vulnerability in Jenkins Compuware Common Configuration Plugin, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41226 and fix it if it is affected.\n\nWhat it is: CVE-2022-41226 is a critical vulnerability in Jenkins Compuware Common Configuration Plugin, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41226 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.compuware.jenkins:compuware-common-configuration (Maven): affected all versions; fixed in 1.0.15\n- com.compuware.jenkins:compuware-common-configuration (Maven): affected all versions; fixed in 1.0.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41226/ (Markdown: https://insights.sbomify.com/CVE-2022-41226/index.md)","id":"CVE-2022-41226","markdown":"https://insights.sbomify.com/CVE-2022-41226/index.md","name":"CVE-2022-41226","record":{"aliases":["GHSA-g43x-pcc9-f472"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Compuware Plugin","requires_auth":"none","summary":"Attackers can exploit XML external entity vulnerabilities in the Jenkins Compuware Common Configuration Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"compuware_common_configuration","vendor":"jenkins"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Compuware Common Configuration Plugin 1.0.14 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Compuware Common Configuration Plugin vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2022-41226","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2022-41227"},"packages":[{"ecosystem":"Maven","fixed":["1.0.15"],"introduced":["0"],"last_affected":[],"package":"com.compuware.jenkins:compuware-common-configuration","purl":null,"source":"GHSA-g43x-pcc9-f472"},{"ecosystem":"Maven","fixed":["1.0.15"],"introduced":["0"],"last_affected":[],"package":"com.compuware.jenkins:compuware-common-configuration","purl":"pkg:maven/com.compuware.jenkins/compuware-common-configuration","source":"GHSA-g43x-pcc9-f472"}],"prev":{"headline":"Jenkins Anchore Container Image Scanner Plugin vulnerable to cross site scripting","id":"CVE-2022-41225"},"products":["Jenkins Compuware Common Configuration Plugin"],"published":"2022-09-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["Jenkins project"]},"summary":"Attackers can exploit XML external entity vulnerabilities in the Jenkins Compuware Common Configuration Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2022-41226/"}