# CVE-2022-41227: Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery

> Attackers can force users to connect to malicious servers with stolen credentials via CSRF in the Jenkins NS-ND Integration Performance Publisher Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2022
- **Updated:** 28 May 2025
- **Also known as:** GHSA-jjch-7g85-4m72

## What is CVE-2022-41227?

CVE-2022-41227 is a high-severity vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-41227?

2 open source packages ship an affected version, including io.jenkins.plugins:cavisson-ns-nd-integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:cavisson-ns-nd-integration` | Maven | All versions | 4.8.0.130 |
| `io.jenkins.plugins:cavisson-ns-nd-integration` | Maven | All versions | 4.8.0.130 |

Products: Jenkins Ns-Nd Integration Performance Publisher.

## How do I fix CVE-2022-41227?

Upgrade io.jenkins.plugins:cavisson-ns-nd-integration to 4.8.0.130 or later.

## Is CVE-2022-41227 being exploited?

There is no known exploitation of CVE-2022-41227 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins NS-ND Integration Performance Publisher Plugin

- [CVE-2022-41228](https://insights.sbomify.com/CVE-2022-41228/): Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Missing Authorization (high 8.8)
- [CVE-2023-33000](https://insights.sbomify.com/CVE-2023-33000/): Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking (high 7.5)
- [CVE-2022-38666](https://insights.sbomify.com/CVE-2022-38666/): SSL/TLS certificate validation unconditionally disabled by Jenkins NS-ND Integration Performance Publisher Plugin (high 7.5)
- [CVE-2022-45391](https://insights.sbomify.com/CVE-2022-45391/): Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally (high 7.5)
- [CVE-2022-45392](https://insights.sbomify.com/CVE-2022-45392/): Plaintext Storage of a Password in Jenkins NS-ND Integration Performance Publisher Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41227 and fix it if it is affected.

What it is: CVE-2022-41227 is a high-severity vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41227 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.130
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.130

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41227/ (Markdown: https://insights.sbomify.com/CVE-2022-41227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41227
- OSV: https://osv.dev/vulnerability/CVE-2022-41227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41227/
Summaries are generated and may contain mistakes; the official description above is the record.
