# CVE-2022-41229: Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-site Scripting

> Stored XSS in Jenkins NS-ND Integration Performance Publisher Plugin allows attackers with configure permissions to execute scripts in other users' browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2022
- **Updated:** 28 May 2025
- **Also known as:** GHSA-fq2h-r2h9-pj8r

## What is CVE-2022-41229?

CVE-2022-41229 is a medium-severity cross-site scripting vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.134 and earlier does not escape configuration options of the Execute NetStorm/NetCloud Test build step, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-41229?

2 open source packages ship an affected version, including io.jenkins.plugins:cavisson-ns-nd-integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:cavisson-ns-nd-integration` | Maven | All versions | 4.8.0.147 |
| `io.jenkins.plugins:cavisson-ns-nd-integration` | Maven | All versions | 4.8.0.147 |

Products: Jenkins Ns-Nd Integration Performance Publisher.

## How do I fix CVE-2022-41229?

Upgrade io.jenkins.plugins:cavisson-ns-nd-integration to 4.8.0.147 or later.

## Is CVE-2022-41229 being exploited?

There is no known exploitation of CVE-2022-41229 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins NS-ND Integration Performance Publisher Plugin

- [CVE-2022-41227](https://insights.sbomify.com/CVE-2022-41227/): Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery (high 8.8)
- [CVE-2022-41228](https://insights.sbomify.com/CVE-2022-41228/): Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Missing Authorization (high 8.8)
- [CVE-2023-33000](https://insights.sbomify.com/CVE-2023-33000/): Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking (high 7.5)
- [CVE-2022-38666](https://insights.sbomify.com/CVE-2022-38666/): SSL/TLS certificate validation unconditionally disabled by Jenkins NS-ND Integration Performance Publisher Plugin (high 7.5)
- [CVE-2022-45391](https://insights.sbomify.com/CVE-2022-45391/): Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41229 and fix it if it is affected.

What it is: CVE-2022-41229 is a medium-severity cross-site scripting vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41229 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.147
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.147

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41229/ (Markdown: https://insights.sbomify.com/CVE-2022-41229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41229
- OSV: https://osv.dev/vulnerability/CVE-2022-41229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41229/
Summaries are generated and may contain mistakes; the official description above is the record.
