CVE-2022-4131 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can cause a Denial of Service on GitLab instances by exploiting a regex issue in user agent parsing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-4131?

CVE-2022-4131 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.8 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. An attacker may cause Denial of Service on a GitLab instance by exploiting a regex issue in how the application parses user agents.

Weakness: CWE-1333

Which versions are affected by CVE-2022-4131?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.8.015.5.7, 15.6.4, 15.7.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-4131?

Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-4131 being exploited?

There is no known exploitation of CVE-2022-4131 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-4131, GHSA-f8ww-p9xj-cm59, UBUNTU-CVE-2022-4131.

Is CVE-2022-4131 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free