# CVE-2022-4131: Denial of service in GitLab

> An attacker can cause a Denial of Service on GitLab instances by exploiting a regex issue in user agent parsing.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2023
- **Updated:** 8 Apr 2025
- **Also known as:** BIT-gitlab-2022-4131, GHSA-f8ww-p9xj-cm59, UBUNTU-CVE-2022-4131

## What is CVE-2022-4131?

CVE-2022-4131 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.8 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. An attacker may cause Denial of Service on a GitLab instance by exploiting a regex issue in how the application parses user agents.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-4131?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 10.8.0 | 15.5.7, 15.6.4, 15.7.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-4131?

Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.

## Is CVE-2022-4131 being exploited?

There is no known exploitation of CVE-2022-4131 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4131 and fix it if it is affected.

What it is: CVE-2022-4131 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4131 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 10.8.0; fixed in 15.5.7, 15.6.4, 15.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4131/ (Markdown: https://insights.sbomify.com/CVE-2022-4131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4131
- OSV: https://osv.dev/vulnerability/CVE-2022-4131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4131/
Summaries are generated and may contain mistakes; the official description above is the record.
