CVE-2022-41317 Information disclosure in n/a
Attackers can expose sensitive client information via HTTPS requests to internal cache manager URLs in Squid proxy servers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41317?
CVE-2022-41317 is a medium-severity vulnerability in Squid-Cache Squid, published on 25 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Squid 4.9 through 4.17 and 5.0.6 through 5.6. Due to inconsistent handling of internal URIs, there can be Exposure of Sensitive Information about clients using the proxy via an HTTPS request to an internal cache manager URL. This is fixed in 5.7.
Weakness: CWE-697
Which versions are affected by CVE-2022-41317?
It affects 1 product.
Products include Squid-Cache Squid.
How do I fix CVE-2022-41317?
Upgrade to a fixed version.
Is CVE-2022-41317 being exploited?
There is no known exploitation of CVE-2022-41317 in the wild and no public exploit code.
Other vulnerabilities in Squid-Cache Squid
- CVE-2025-62168 Squid vulnerable to information disclosure via authentication credential leakage in error handling
- CVE-2025-54574 Squid's URN Handling can lead to Buffer Overflow
- CVE-2026-33526 Squid vulnerable to Denial of Service in ICP Request handling
- CVE-2026-32748 Squid has Denial of Service in ICP Response handling
- CVE-2023-50269 SQUID-2023:10 Denial of Service in HTTP Request parsing
Sources
Also known as ALPINE-CVE-2022-41317, CLSA-2026-1778252773, DEBIAN-CVE-2022-41317, GHSA-rcg9-7fqm-83mq, UBUNTU-CVE-2022-41317.