# CVE-2022-41323: Django denial-of-service vulnerability in internationalized URLs

> Attackers can cause denial of service in Django applications by exploiting the locale parameter in internationalized URLs, which is treated as a regular expression.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2022
- **Updated:** 14 May 2025
- **Also known as:** BIT-django-2022-41323, CLSA-2025-1756426301, DEBIAN-CVE-2022-41323, GHSA-qrw5-5h28-6cmg, PYSEC-2022-304, UBUNTU-CVE-2022-41323, USN-5653-1, openSUSE-SU-2024:12396-1

## What is CVE-2022-41323?

CVE-2022-41323 is a high-severity denial of service vulnerability in Djangoproject Django, published on 16 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular expression.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-41323?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.16, 4.0.8, 4.1.2 |
| `django` | PyPI | From 3.2 | 3.2.16, 4.0.8, 4.1.2 |
| `django` | PyPI | From 3.2 | 3.2.16 |
| `django` | PyPI | From 4.0 | 4.0.8 |
| `django` | PyPI | From 4.1 | 4.1.2 |
| `Django` | PyPI | From 3.2 | 3.2.16 |
| `Django` | PyPI | From 4.0 | 4.0.8 |
| `Django` | PyPI | From 4.1 | 4.1.2 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.1.2-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2022-41323?

Upgrade django to a fixed version for your release line: 3.2.16, 4.0.8 or 4.1.2.

## Is CVE-2022-41323 being exploited?

There is no known exploitation of CVE-2022-41323 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41323 and fix it if it is affected.

What it is: CVE-2022-41323 is a high-severity denial of service vulnerability in Djangoproject Django, published on 16 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41323 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.16, 4.0.8, 4.1.2
- django (PyPI): affected from 3.2; fixed in 3.2.16, 4.0.8, 4.1.2
- django (PyPI): affected from 3.2; fixed in 3.2.16
- django (PyPI): affected from 4.0; fixed in 4.0.8
- django (PyPI): affected from 4.1; fixed in 4.1.2
- Django (PyPI): affected from 3.2; fixed in 3.2.16
- Django (PyPI): affected from 4.0; fixed in 4.0.8
- Django (PyPI): affected from 4.1; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41323/ (Markdown: https://insights.sbomify.com/CVE-2022-41323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41323
- OSV: https://osv.dev/vulnerability/CVE-2022-41323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41323/
Summaries are generated and may contain mistakes; the official description above is the record.
