{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41325 exists.","fix":"Apply the vendor's patch.","what":"CVE-2022-41325 is a high-severity vulnerability in Debian Debian Linux, published on 6 Dec 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-41325 and fix it if it is affected.\n\nWhat it is: CVE-2022-41325 is a high-severity vulnerability in Debian Debian Linux, published on 6 Dec 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41325 exists.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41325/ (Markdown: https://insights.sbomify.com/CVE-2022-41325/index.md)","id":"CVE-2022-41325","markdown":"https://insights.sbomify.com/CVE-2022-41325/index.md","name":"CVE-2022-41325","record":{"aliases":["DEBIAN-CVE-2022-41325","DLA-3216-1","DSA-5297-1","GHSA-xxf6-mj48-xcg3","UBUNTU-CVE-2022-41325","openSUSE-SU-2022:10255-1","openSUSE-SU-2024:12582-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"VLC Media Player","requires_auth":"none","summary":"Integer overflow in VLC's VNC module allows attackers to crash the application or execute code via crafted playlists or rogue servers.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"vlc_media_player","vendor":"videolan"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.","ecosystems":["SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2022-41325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","videolan:vlc_media_player"],"type":"integer_overflow","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"File upload in n/a","id":"CVE-2022-41326"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["3.0.18-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"vlc","purl":"pkg:rpm/suse/vlc\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10255-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.0.18-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"vlc","purl":"pkg:rpm/opensuse/vlc\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10255-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0.18-4.1"],"introduced":["0"],"last_affected":[],"package":"vlc","purl":"pkg:rpm/opensuse/vlc\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12582-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2022-41324"},"products":["n/a"],"published":"2022-12-06","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["n/a"]},"summary":"Integer overflow in VLC's VNC module allows attackers to crash the application or execute code via crafted playlists or rogue servers.","url":"https://insights.sbomify.com/CVE-2022-41325/"}