{"answers":{"affected":"2 open source packages ship an affected version, including @lionello/secp256k1-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41340 in the wild and no public exploit code.","fix":"Upgrade @lionello/secp256k1-js to 1.1.0 or later.","what":"CVE-2022-41340 is a high-severity vulnerability in n/a, published on 24 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41340 and fix it if it is affected.\n\nWhat it is: CVE-2022-41340 is a high-severity vulnerability in n/a, published on 24 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41340 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @lionello/secp256k1-js (npm): affected all versions; fixed in 1.1.0\n- @lionello/secp256k1-js (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41340/ (Markdown: https://insights.sbomify.com/CVE-2022-41340/index.md)","id":"CVE-2022-41340","markdown":"https://insights.sbomify.com/CVE-2022-41340/index.md","name":"CVE-2022-41340","record":{"aliases":["GHSA-q3f4-9h4p-vgr3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js crypto library","requires_auth":"none","summary":"Attackers can forge ECDSA signatures due to missing validation in secp256k1-js, compromising cryptographic integrity for Node.js applications.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"secp256k1-js","vendor":"secp256k1-js_project"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"secp256k1-js implements ECDSA without required r and s validation, leading to signature forgery","id":"CVE-2022-41340","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-41341"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@lionello/secp256k1-js","purl":null,"source":"GHSA-q3f4-9h4p-vgr3"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@lionello/secp256k1-js","purl":"pkg:npm/%40lionello/secp256k1-js","source":"GHSA-q3f4-9h4p-vgr3"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2022-41339"},"products":["n/a"],"published":"2022-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-22","vendors":["n/a"]},"summary":"Attackers can forge ECDSA signatures due to missing validation in secp256k1-js, compromising cryptographic integrity for Node.js applications.","url":"https://insights.sbomify.com/CVE-2022-41340/"}