# CVE-2022-41340: secp256k1-js implements ECDSA without required r and s validation, leading to signature forgery

> Attackers can forge ECDSA signatures due to missing validation in secp256k1-js, compromising cryptographic integrity for Node.js applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2022
- **Updated:** 22 May 2025
- **Also known as:** GHSA-q3f4-9h4p-vgr3

## What is CVE-2022-41340?

CVE-2022-41340 is a high-severity vulnerability in n/a, published on 24 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2022-41340?

2 open source packages ship an affected version, including @lionello/secp256k1-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lionello/secp256k1-js` | npm | All versions | 1.1.0 |
| `@lionello/secp256k1-js` | npm | All versions | 1.1.0 |

Products: Secp256k1-Js Project Secp256k1-Js.

## How do I fix CVE-2022-41340?

Upgrade @lionello/secp256k1-js to 1.1.0 or later.

## Is CVE-2022-41340 being exploited?

There is no known exploitation of CVE-2022-41340 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41340 and fix it if it is affected.

What it is: CVE-2022-41340 is a high-severity vulnerability in n/a, published on 24 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41340 in the wild and no public exploit code.

Affected packages and fixed versions:
- @lionello/secp256k1-js (npm): affected all versions; fixed in 1.1.0
- @lionello/secp256k1-js (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41340/ (Markdown: https://insights.sbomify.com/CVE-2022-41340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41340
- OSV: https://osv.dev/vulnerability/CVE-2022-41340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41340/
Summaries are generated and may contain mistakes; the official description above is the record.
