# CVE-2022-4135: Google Chromium GPU Heap Buffer Overflow

> A heap buffer overflow in Chrome's GPU process allows remote attackers to escape the sandbox and execute arbitrary code via a crafted HTML page.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 28 Nov 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2022
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2022-4135, DSA-5289-1, GHSA-995f-9x5r-2rcj, UBUNTU-CVE-2022-4135, openSUSE-SU-2022:10221-1, openSUSE-SU-2024:12538-1

## What is CVE-2022-4135?

CVE-2022-4135 is a critical memory corruption vulnerability in Google Chrome, published on 25 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Heap buffer overflow in GPU in Google Chrome prior to 107.0.5304.121 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. (Chromium security severity: High)

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-4135?

2 open source packages ship an affected version, including electron. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 19.0.0 | 19.1.8 |
| `electron` | npm | From 19.0.0 | 19.1.8 |
| `chromium` | SUSE:Package Hub 15 SP3 | All versions | 107.0.5304.121-bp154.2.46.1 |
| `chromium` | SUSE:Package Hub 15 SP4 | All versions | 107.0.5304.121-bp154.2.46.1 |
| `chromium` | openSUSE:Leap 15.3 | All versions | 107.0.5304.121-bp154.2.46.1 |
| `chromium` | openSUSE:Leap 15.4 | All versions | 107.0.5304.121-bp154.2.46.1 |
| `chromium` | openSUSE:Tumbleweed | All versions | 107.0.5304.121-1.1 |

Products: Google Chrome, Microsoft Edge, Microsoft Edge Chromium.

## How do I fix CVE-2022-4135?

Upgrade electron to 19.1.8 or later. US federal agencies must fix it by 19 Dec 2022.

## Is CVE-2022-4135 being exploited?

Yes. Attackers have exploited CVE-2022-4135 in the wild since at least 28 Nov 2022.

## Other vulnerabilities in Google Chrome

- [CVE-2020-16017](https://insights.sbomify.com/CVE-2020-16017/): Google Chrome Use-After-Free (critical 9.6, exploited in the wild)
- [CVE-2020-16010](https://insights.sbomify.com/CVE-2020-16010/): Google Chrome for Android UI Heap Buffer Overflow (critical 9.6, exploited in the wild)
- [CVE-2026-87491](https://insights.sbomify.com/CVE-2026-87491/): Google Chromium V8 Out of Bounds Write (high 8.8, exploited in the wild)
- [CVE-2026-85046](https://insights.sbomify.com/CVE-2026-85046/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)
- [CVE-2026-11645](https://insights.sbomify.com/CVE-2026-11645/): Google Chromium V8 Out-of-Bounds Read and Write (high 8.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4135 and fix it if it is affected.

What it is: CVE-2022-4135 is a critical memory corruption vulnerability in Google Chrome, published on 25 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2022-4135 in the wild since at least 28 Nov 2022.

Affected packages and fixed versions:
- electron (npm): affected from 19.0.0; fixed in 19.1.8
- electron (npm): affected from 19.0.0; fixed in 19.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4135/ (Markdown: https://insights.sbomify.com/CVE-2022-4135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4135
- OSV: https://osv.dev/vulnerability/CVE-2022-4135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4135/
Summaries are generated and may contain mistakes; the official description above is the record.
