# CVE-2022-4137: Keycloak: reflected xss attack

> Reflected XSS in Keycloak's OAuth endpoint allows attackers to inject scripts via malicious links, potentially compromising user data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9hhc-pj4w-w5rv

## What is CVE-2022-4137?

CVE-2022-4137 is a high-severity cross-site scripting vulnerability in Redhat Keycloak, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site scripting (XSS) vulnerability was found in the 'oob' OAuth endpoint due to incorrect null-byte handling. This issue allows a malicious link to insert an arbitrary URI into a Keycloak error page. This flaw requires a user or administrator to interact with a link in order to be vulnerable. This may compromise user details, allowing it to be changed or collected by an attacker.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-81 (Improper Neutralization of Script in an Error Message Web Page)

## Which versions are affected by CVE-2022-4137?

2 open source packages ship an affected version, including org.keycloak:keycloak-parent. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-parent` | Maven | All versions | 20.0.5 |
| `org.keycloak:keycloak-parent` | Maven | All versions | 20.0.5 |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2022-4137?

Upgrade org.keycloak:keycloak-parent to 20.0.5 or later.

## Is CVE-2022-4137 being exploited?

There is no known exploitation of CVE-2022-4137 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/keycloak__keycloak_CVE-2022-4137_20-0-3 (github_poc): https://github.com/shoucheng3/keycloak__keycloak_CVE-2022-4137_20-0-3

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4137 and fix it if it is affected.

What it is: CVE-2022-4137 is a high-severity cross-site scripting vulnerability in Redhat Keycloak, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4137 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-parent (Maven): affected all versions; fixed in 20.0.5
- org.keycloak:keycloak-parent (Maven): affected all versions; fixed in 20.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4137/ (Markdown: https://insights.sbomify.com/CVE-2022-4137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4137
- OSV: https://osv.dev/vulnerability/CVE-2022-4137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4137/
Summaries are generated and may contain mistakes; the official description above is the record.
