CVE-2022-4138 Cross-site request forgery in GitLab

Medium 6.4 Published Updated

An attacker can take over a project if an Owner or Maintainer uploads a file to a malicious project via CSRF.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-4138?

CVE-2022-4138 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A Cross Site Request Forgery issue has been discovered in GitLab CE/EE affecting all versions before 15.6.7, all versions starting from 15.7 before 15.7.6, and all versions starting from 15.8 before 15.8.1. An attacker could take over a project if an Owner or Maintainer uploads a file to a malicious project.

Weakness: CWE-352

Which versions are affected by CVE-2022-4138?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.015.6.7, 15.7.6, 15.8.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-4138?

Upgrade gitlab to a fixed version for your release line: 15.6.7, 15.7.6 or 15.8.1.

Is CVE-2022-4138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4138 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-4138, GHSA-4m8h-w9w3-cp2v, UBUNTU-CVE-2022-4138.

Is CVE-2022-4138 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free