CVE-2022-41401 OpenRefine Server-Side Request Forgery vulnerability

Medium 6.5 Published Updated

Attackers can exploit SSRF in OpenRefine to access internal resources and disclose sensitive files without authorization.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41401?

CVE-2022-41401 is a medium-severity server-side request forgery vulnerability in n/a, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenRefine <= v3.5.2 contains a Server-Side Request Forgery (SSRF) vulnerability, which permits unauthorized users to exploit the system, potentially leading to unauthorized access to internal resources and sensitive file disclosure.

Weakness: CWE-918

Which versions are affected by CVE-2022-41401?

2 open source packages ship an affected version, including org.openrefine:main. It affects 1 product.

PackageAffectedFixed in
org.openrefine:main MavenAll versions3.6.0
org.openrefine:main MavenAll versions3.6.0

Products include Openrefine Openrefine.

How do I fix CVE-2022-41401?

Upgrade org.openrefine:main to 3.6.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2022-41401 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41401 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as DEBIAN-CVE-2022-41401, GHSA-q7mc-fc87-v7w7, UBUNTU-CVE-2022-41401.

Is CVE-2022-41401 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free