# CVE-2022-41401: OpenRefine Server-Side Request Forgery vulnerability

> Attackers can exploit SSRF in OpenRefine to access internal resources and disclose sensitive files without authorization.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2023
- **Updated:** 17 Oct 2024
- **Also known as:** DEBIAN-CVE-2022-41401, GHSA-q7mc-fc87-v7w7, UBUNTU-CVE-2022-41401

## What is CVE-2022-41401?

CVE-2022-41401 is a medium-severity server-side request forgery vulnerability in n/a, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRefine <= v3.5.2 contains a Server-Side Request Forgery (SSRF) vulnerability, which permits unauthorized users to exploit the system, potentially leading to unauthorized access to internal resources and sensitive file disclosure.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-41401?

2 open source packages ship an affected version, including org.openrefine:main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openrefine:main` | Maven | All versions | 3.6.0 |
| `org.openrefine:main` | Maven | All versions | 3.6.0 |

Products: Openrefine Openrefine.

## How do I fix CVE-2022-41401?

Upgrade org.openrefine:main to 3.6.0 or later.

## Is CVE-2022-41401 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41401 exists.

Public exploit code:

- https://github.com/ixSly/CVE-2022-41401 (github_poc): https://github.com/ixSly/CVE-2022-41401

## Other vulnerabilities in n/a

- [CVE-2023-41887](https://insights.sbomify.com/CVE-2023-41887/): Remote Code exec in project import with mysql jdbc url attack (critical 9.8)
- [CVE-2024-47878](https://insights.sbomify.com/CVE-2024-47878/): Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt) (high 8.1)
- [CVE-2024-47880](https://insights.sbomify.com/CVE-2024-47880/): OpenRefine has a reflected cross-site scripting vulnerability from POST request in ExportRowsCommand (high 8.1)
- [CVE-2024-47881](https://insights.sbomify.com/CVE-2024-47881/): OpenRefine's SQLite integration allows filesystem access, remote code execution (RCE) (high 8.1)
- [CVE-2024-47879](https://insights.sbomify.com/CVE-2024-47879/): OpenRefine's PreviewExpressionCommand, which is eval, lacks protection against cross-site request forgery (CSRF) (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41401 and fix it if it is affected.

What it is: CVE-2022-41401 is a medium-severity server-side request forgery vulnerability in n/a, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41401 exists.

Affected packages and fixed versions:
- org.openrefine:main (Maven): affected all versions; fixed in 3.6.0
- org.openrefine:main (Maven): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41401/ (Markdown: https://insights.sbomify.com/CVE-2022-41401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41401
- OSV: https://osv.dev/vulnerability/CVE-2022-41401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41401/
Summaries are generated and may contain mistakes; the official description above is the record.
