CVE-2022-4143 Race condition in GitLab
Attackers can merge unapproved merge requests without authorization due to a race condition, requiring GitLab administrators to upgrade.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-4143?
CVE-2022-4143 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.7 before 15.8.5, from 15.9 before 15.9.4, and from 15.10 before 15.10.1 that allows for crafted, unapproved MRs to be introduced and merged without authorization
Weakness: CWE-367
Which versions are affected by CVE-2022-4143?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.7.0 | 15.8.5, 15.9.4, 15.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4143?
Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.
Is CVE-2022-4143 being exploited?
There is no known exploitation of CVE-2022-4143 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4143, GHSA-9xhf-gx34-9q2g, UBUNTU-CVE-2022-4143.