# CVE-2022-41547: MobSF allows attackers to read arbitrary files via a crafted HTTP request

> Attackers can read arbitrary files via crafted HTTP requests in MobSF, exposing sensitive data to unauthorized users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2022
- **Updated:** 10 May 2025
- **Also known as:** GHSA-f42p-vc8p-7x54, PYSEC-2026-848

## What is CVE-2022-41547?

CVE-2022-41547 is a high-severity path traversal vulnerability in n/a, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mobile Security Framework (MobSF) v0.9.2 and below was discovered to contain a local file inclusion (LFI) vulnerability in the StaticAnalyzer/views.py script. This vulnerability allows attackers to read arbitrary files via a crafted HTTP request.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2022-41547?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 0.9.3 |
| `mobsf` | PyPI | All versions | 0.9.3 |
| `mobsf` | PyPI | All versions | 0.9.3 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2022-41547?

Upgrade mobsf to 0.9.3 or later.

## Is CVE-2022-41547 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41547 exists.

## Other vulnerabilities in n/a

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41547 and fix it if it is affected.

What it is: CVE-2022-41547 is a high-severity path traversal vulnerability in n/a, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41547 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 0.9.3
- mobsf (PyPI): affected all versions; fixed in 0.9.3
- mobsf (PyPI): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41547/ (Markdown: https://insights.sbomify.com/CVE-2022-41547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41547
- OSV: https://osv.dev/vulnerability/CVE-2022-41547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41547/
Summaries are generated and may contain mistakes; the official description above is the record.
