CVE-2022-41556 Denial of service in n/a
A resource leak in lighttpd allows attackers to cause denial of service via connection-slot exhaustion using anomalous TCP behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41556?
CVE-2022-41556 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.
Weakness: CWE-401
Which versions are affected by CVE-2022-41556?
It affects 2 products.
Linux distribution packages (5)
lighttpd SUSE:Package Hub 15 SP3 | All versions | 1.4.67-bp154.2.6.1 |
lighttpd SUSE:Package Hub 15 SP4 | All versions | 1.4.67-bp154.2.6.1 |
lighttpd openSUSE:Leap 15.3 | All versions | 1.4.67-bp154.2.6.1 |
lighttpd openSUSE:Leap 15.4 | All versions | 1.4.67-bp154.2.6.1 |
lighttpd openSUSE:Tumbleweed | All versions | 1.4.67-2.1 |
Products include Fedoraproject Fedora, Lighttpd Lighttpd.
How do I fix CVE-2022-41556?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-41556 being exploited?
There is no known exploitation of CVE-2022-41556 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2022-41556, DEBIAN-CVE-2022-41556, GHSA-jm88-vr5q-23rj, UBUNTU-CVE-2022-41556, openSUSE-SU-2022:10140-1, openSUSE-SU-2024:12382-1.