{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-41556 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-41556 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41556 and fix it if it is affected.\n\nWhat it is: CVE-2022-41556 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41556 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41556/ (Markdown: https://insights.sbomify.com/CVE-2022-41556/index.md)","id":"CVE-2022-41556","markdown":"https://insights.sbomify.com/CVE-2022-41556/index.md","name":"CVE-2022-41556","record":{"aliases":["ALPINE-CVE-2022-41556","DEBIAN-CVE-2022-41556","GHSA-jm88-vr5q-23rj","UBUNTU-CVE-2022-41556","openSUSE-SU-2022:10140-1","openSUSE-SU-2024:12382-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"lighttpd web server","requires_auth":"none","summary":"A resource leak in lighttpd allows attackers to cause denial of service via connection-slot exhaustion using anomalous TCP behavior.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"lighttpd","vendor":"lighttpd"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-401","name":"Missing Release of Memory after Effective Lifetime"}],"description":"A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.","ecosystems":["SUSE:Package Hub 15 SP3","SUSE:Package Hub 15 SP4","openSUSE:Leap 15.3","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-41556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2022"},"n_packages":5,"n_references":5,"next":{"headline":"TIBCO Spotfire Stored Cross Site Scripting (XSS) Vulnerability","id":"CVE-2022-41558"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["1.4.67-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"lighttpd","purl":"pkg:rpm/suse/lighttpd\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:10140-1"},{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["1.4.67-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"lighttpd","purl":"pkg:rpm/suse/lighttpd\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10140-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["1.4.67-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"lighttpd","purl":"pkg:rpm/opensuse/lighttpd\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:10140-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["1.4.67-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"lighttpd","purl":"pkg:rpm/opensuse/lighttpd\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10140-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.67-2.1"],"introduced":["0"],"last_affected":[],"package":"lighttpd","purl":"pkg:rpm/opensuse/lighttpd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12382-1"}],"prev":{"headline":"Delta Electronics DIAEnergie","id":"CVE-2022-41555"},"products":["n/a"],"published":"2022-10-06","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A resource leak in lighttpd allows attackers to cause denial of service via connection-slot exhaustion using anomalous TCP behavior.","url":"https://insights.sbomify.com/CVE-2022-41556/"}