# CVE-2022-41556: Denial of service in n/a

> A resource leak in lighttpd allows attackers to cause denial of service via connection-slot exhaustion using anomalous TCP behavior.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-41556, DEBIAN-CVE-2022-41556, GHSA-jm88-vr5q-23rj, UBUNTU-CVE-2022-41556, openSUSE-SU-2022:10140-1, openSUSE-SU-2024:12382-1

## What is CVE-2022-41556?

CVE-2022-41556 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2022-41556?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lighttpd` | SUSE:Package Hub 15 SP3 | All versions | 1.4.67-bp154.2.6.1 |
| `lighttpd` | SUSE:Package Hub 15 SP4 | All versions | 1.4.67-bp154.2.6.1 |
| `lighttpd` | openSUSE:Leap 15.3 | All versions | 1.4.67-bp154.2.6.1 |
| `lighttpd` | openSUSE:Leap 15.4 | All versions | 1.4.67-bp154.2.6.1 |
| `lighttpd` | openSUSE:Tumbleweed | All versions | 1.4.67-2.1 |

Products: Fedoraproject Fedora, Lighttpd Lighttpd.

## How do I fix CVE-2022-41556?

Upgrade to a fixed version.

## Is CVE-2022-41556 being exploited?

There is no known exploitation of CVE-2022-41556 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41556 and fix it if it is affected.

What it is: CVE-2022-41556 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41556 in the wild and no public exploit code.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41556/ (Markdown: https://insights.sbomify.com/CVE-2022-41556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41556
- OSV: https://osv.dev/vulnerability/CVE-2022-41556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41556/
Summaries are generated and may contain mistakes; the official description above is the record.
