# CVE-2022-41563: TIBCO JasperReports Server Stored XSS Vulnerability

> A low-privileged attacker can inject malicious scripts into the Dashboard component, potentially compromising user sessions or executing code when victims view the page.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-jasperreports-2022-41563, GHSA-2wj3-4hph-hjgw, UBUNTU-CVE-2022-41563

## What is CVE-2022-41563?

CVE-2022-41563 is a critical cross-site scripting vulnerability in TIBCO JasperReports Server, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Dashboard component of TIBCO Software Inc.'s TIBCO JasperReports Server, TIBCO JasperReports Server, TIBCO JasperReports Server - Developer Edition, TIBCO JasperReports Server for AWS Marketplace, TIBCO JasperReports Server for AWS Marketplace, TIBCO JasperReports Server for Microsoft Azure, and TIBCO JasperReports Server for Microsoft Azure contains an easily exploitable vulnerability that allows a low privileged attacker with network access to execute Stored Cross Site Scripting (XSS) on the affected system. A successful attack using this vulnerability requires human interaction from a person other than the attacker. Affected releases are TIBCO Software Inc.'s TIBCO JasperReports Server: versions 8.0.2 and below, TIBCO JasperReports Server: version 8.1.0, TIBCO JasperReports Server - Developer Edition: versions 8.1.0 and below, TIBCO JasperReports Server for AWS Marketplace: versions 8.0.2 and below, TIBCO JasperReports Server for AWS Marketplace: version 8.1.0, TIBCO JasperReports Server for Microsoft Azure: versions 8.0.2 and below, and TIBCO JasperReports Server for Microsoft Azure: version 8.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-41563?

1 open source package ship an affected version, including jasperreports. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jasperreports` | Bitnami | All versions to 8.1.0 | 8.0.2 |

Products: Tibco Jasperreports Server.

## How do I fix CVE-2022-41563?

Upgrade jasperreports to 8.0.2 or later.

## Is CVE-2022-41563 being exploited?

There is no known exploitation of CVE-2022-41563 in the wild and no public exploit code.

## Other vulnerabilities in TIBCO JasperReports Server

- [CVE-2018-5430](https://insights.sbomify.com/CVE-2018-5430/): TIBCO JasperReports Server Information Disclosure (high 7.7, exploited in the wild)
- [CVE-2018-18815](https://insights.sbomify.com/CVE-2018-18815/): TIBCO JasperReports Server User Information Disclosure (critical 10.0)
- [CVE-2017-5533](https://insights.sbomify.com/CVE-2017-5533/): TIBCO JasperReports Server credentials disclosure (critical 9.3)
- [CVE-2022-41561](https://insights.sbomify.com/CVE-2022-41561/): TIBCO JasperReports Server RCE Vulnerability (critical 9.1)
- [CVE-2021-35495](https://insights.sbomify.com/CVE-2021-35495/): TIBCO JasperReports FTP Password exposed (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41563 and fix it if it is affected.

What it is: CVE-2022-41563 is a critical cross-site scripting vulnerability in TIBCO JasperReports Server, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41563 in the wild and no public exploit code.

Affected packages and fixed versions:
- jasperreports (Bitnami): affected all versions up to 8.1.0; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41563/ (Markdown: https://insights.sbomify.com/CVE-2022-41563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41563
- OSV: https://osv.dev/vulnerability/CVE-2022-41563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41563/
Summaries are generated and may contain mistakes; the official description above is the record.
