# CVE-2022-41574: Missing authorization in n/a

> Remote attackers can disrupt backups and send arbitrary emails to administrators via an exposed internal endpoint in Gradle Enterprise.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2h8w-grhw-cqcr

## What is CVE-2022-41574?

CVE-2022-41574 is a high-severity missing authorization vulnerability in n/a, published on 7 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An access-control vulnerability in Gradle Enterprise 2022.4 through 2022.3.1 allows remote attackers to prevent backups from occurring, and send emails with arbitrary text content to the configured installation-administrator contact address, via HTTP access to an accidentally exposed internal endpoint. This is fixed in 2022.3.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-41574?

It affects 1 product.


Products: Gradle Enterprise.

## How do I fix CVE-2022-41574?

No fix has been published for CVE-2022-41574 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-41574 being exploited?

There is no known exploitation of CVE-2022-41574 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-49238](https://insights.sbomify.com/CVE-2023-49238/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2022-27919](https://insights.sbomify.com/CVE-2022-27919/): Missing authorization in n/a (critical 9.8)
- [CVE-2019-11402](https://insights.sbomify.com/CVE-2019-11402/): Information disclosure in n/a (critical 9.8)
- [CVE-2020-15776](https://insights.sbomify.com/CVE-2020-15776/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2022-25364](https://insights.sbomify.com/CVE-2022-25364/): Misconfiguration in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41574 and fix it if it is affected.

What it is: CVE-2022-41574 is a high-severity missing authorization vulnerability in n/a, published on 7 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41574 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41574/ (Markdown: https://insights.sbomify.com/CVE-2022-41574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41574
- OSV: https://osv.dev/vulnerability/CVE-2022-41574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41574/
Summaries are generated and may contain mistakes; the official description above is the record.
