CVE-2022-41606 Nomad Panics On Job Submission With Bad Artifact Stanza Source URL

Medium 6.5 Published Updated

Attackers can crash Nomad client agents by submitting jobs with invalid S3 or GCS artifact URLs, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41606?

CVE-2022-41606 is a medium-severity denial of service vulnerability in n/a, published on 11 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

HashiCorp Nomad and Nomad Enterprise 1.0.2 up to 1.2.12, and 1.3.5 jobs submitted with an artifact stanza using invalid S3 or GCS URLs can be used to crash client agents. Fixed in 1.2.13, 1.3.6, and 1.4.0.

Weakness: CWE-20

Which versions are affected by CVE-2022-41606?

5 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions1.2.13, 1.3.6
github.com/hashicorp/nomad GoAll versions1.2.13
github.com/hashicorp/nomad GoAll versions1.2.13
github.com/hashicorp/nomad GoFrom 1.3.01.3.6
github.com/hashicorp/nomad GoFrom 1.3.01.3.6

Products include Hashicorp Nomad.

How do I fix CVE-2022-41606?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.2.13 or 1.3.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-41606 being exploited?

There is no known exploitation of CVE-2022-41606 in the wild and no public exploit code.

Sources

Also known as GHSA-7v3g-4878-5qrf, GO-2022-1062, UBUNTU-CVE-2022-41606.

Is CVE-2022-41606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free