{"answers":{"affected":"2 open source packages ship an affected version, including nadesiko3. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41642 in the wild and no public exploit code.","fix":"Upgrade nadesiko3 to 3.3.69 or later.","what":"CVE-2022-41642 is a critical command injection vulnerability in kujirahand Nadesiko3 (PC Version), published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41642 and fix it if it is affected.\n\nWhat it is: CVE-2022-41642 is a critical command injection vulnerability in kujirahand Nadesiko3 (PC Version), published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41642 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nadesiko3 (npm): affected all versions; fixed in 3.3.69\n- nadesiko3 (npm): affected all versions; fixed in 3.3.69\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41642/ (Markdown: https://insights.sbomify.com/CVE-2022-41642/index.md)","id":"CVE-2022-41642","markdown":"https://insights.sbomify.com/CVE-2022-41642/index.md","name":"CVE-2022-41642","record":{"aliases":["GHSA-m8r5-7wf4-63mw"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Nadesiko3 PC Version","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via compression features in Nadesiko3 PC Version, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"nadesiko3","vendor":"kujirahand"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"OS command injection vulnerability in Nadesiko3 (PC Version) v3.3.61 and earlier allows a remote attacker to execute an arbitrary OS command when processing compression and decompression on the product.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nadesiko3 OS Command Injection vulnerability","id":"CVE-2022-41642","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"WordPress Accessibility plugin \u003c= 1.0.3 - Auth. Stored Cross-Site Scripting (XSS) vulnerability","id":"CVE-2022-41643"},"packages":[{"ecosystem":"npm","fixed":["3.3.69"],"introduced":["0"],"last_affected":[],"package":"nadesiko3","purl":null,"source":"GHSA-m8r5-7wf4-63mw"},{"ecosystem":"npm","fixed":["3.3.69"],"introduced":["0"],"last_affected":[],"package":"nadesiko3","purl":"pkg:npm/nadesiko3","source":"GHSA-m8r5-7wf4-63mw"}],"prev":{"headline":"WordPress Wholesale Suite Plugin \u003c= 2.1.5 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2022-41640"},"products":["Nadesiko3 (PC Version)"],"published":"2022-12-05","related":[{"cvss_score":9.8,"headline":"nadesiko3 vulnerable to OS Command Injection","id":"CVE-2022-42496","kev_date_added":null,"published":"2022-12-05"},{"cvss_score":7.5,"headline":"nadesiko3 allows remote attacker to inject invalid value to decodeURIComponent of nako3edit","id":"CVE-2022-41777","kev_date_added":null,"published":"2022-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-24","vendors":["kujirahand"]},"summary":"Remote attackers can execute arbitrary OS commands via compression features in Nadesiko3 PC Version, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-41642/"}