CVE-2022-4167 Missing authorization in GitLab
Group access tokens remain valid after the owner loses revocation rights, allowing unauthorized access in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-4167?
CVE-2022-4167 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 12 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Incorrect Authorization check affecting all versions of GitLab EE from 13.11 prior to 15.5.7, 15.6 prior to 15.6.4, and 15.7 prior to 15.7.2 allows group access tokens to continue working even after the group owner loses the ability to revoke them.
Weakness: CWE-863
Which versions are affected by CVE-2022-4167?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.11.0 | 15.5.7, 15.6.4, 15.7.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4167?
Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-4167 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4167 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4167, GHSA-wf4m-rq68-3mfc, UBUNTU-CVE-2022-4167.