CVE-2022-41672 Session still functional after user is deactivated

High 8.1 Published Updated

Deactivated users retain active sessions, allowing continued access to the UI and API in Apache Airflow.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41672?

CVE-2022-41672 is a high-severity authentication bypass vulnerability in Apache Airflow, published on 7 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Airflow, prior to version 2.4.1, deactivating a user wouldn't prevent an already authenticated user from being able to continue using the UI or API.

Weakness: CWE-613

Which versions are affected by CVE-2022-41672?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.4.1rc1
apache-airflow PyPIAll versions2.4.1rc1
apache-airflow PyPIAll versions2.4.2rc1
airflow BitnamiAll versions2.4.2

Products include Apache Airflow.

How do I fix CVE-2022-41672?

Upgrade apache-airflow to a fixed version for your release line: 2.4.1rc1 or 2.4.2rc1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-41672 being exploited?

There is no known exploitation of CVE-2022-41672 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2022-41672, GHSA-3q8r-f3pj-3gc4, PYSEC-2022-42983.

Is CVE-2022-41672 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free