# CVE-2022-41672: Session still functional after user is deactivated

> Deactivated users retain active sessions, allowing continued access to the UI and API in Apache Airflow.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-airflow-2022-41672, GHSA-3q8r-f3pj-3gc4, PYSEC-2022-42983

## What is CVE-2022-41672?

CVE-2022-41672 is a high-severity authentication bypass vulnerability in Apache Airflow, published on 7 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Airflow, prior to version 2.4.1, deactivating a user wouldn't prevent an already authenticated user from being able to continue using the UI or API.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-41672?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.4.1rc1 |
| `apache-airflow` | PyPI | All versions | 2.4.1rc1 |
| `apache-airflow` | PyPI | All versions | 2.4.2rc1 |
| `airflow` | Bitnami | All versions | 2.4.2 |

Products: Apache Airflow.

## How do I fix CVE-2022-41672?

Upgrade apache-airflow to a fixed version for your release line: 2.4.1rc1 or 2.4.2rc1.

## Is CVE-2022-41672 being exploited?

There is no known exploitation of CVE-2022-41672 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41672 and fix it if it is affected.

What it is: CVE-2022-41672 is a high-severity authentication bypass vulnerability in Apache Airflow, published on 7 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41672 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.4.1rc1
- apache-airflow (PyPI): affected all versions; fixed in 2.4.1rc1
- apache-airflow (PyPI): affected all versions; fixed in 2.4.2rc1
- airflow (Bitnami): affected all versions; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41672/ (Markdown: https://insights.sbomify.com/CVE-2022-41672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41672
- OSV: https://osv.dev/vulnerability/CVE-2022-41672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41672/
Summaries are generated and may contain mistakes; the official description above is the record.
