CVE-2022-41703 Apache Superset: SQL injection vulnerability in adhoc clauses
Authenticated users can bypass subquery restrictions to read unauthorized database tables via SQL injection in Apache Superset.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41703?
CVE-2022-41703 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability in the SQL Alchemy connector of Apache Superset allows an authenticated user with read access to a specific database to add subqueries to the WHERE and HAVING fields referencing tables on the same database that the user should not have access to, despite the user having the feature flag "ALLOW_ADHOC_SUBQUERY" disabled (default value). This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
Weakness: CWE-89
Which versions are affected by CVE-2022-41703?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | 1.5.3, 2.0.1 |
apache-superset PyPI | All versions to 1.5.2 | None |
apache-superset PyPI | All versions to 1.5.2 | None |
superset Bitnami | All versions | 1.5.3, 2.0.1 |
Products include Apache Superset.
How do I fix CVE-2022-41703?
Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2022-41703 being exploited?
There is no known exploitation of CVE-2022-41703 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2022-41703, GHSA-cxvp-3frm-3876, PYSEC-2026-780.