# CVE-2022-41703: Apache Superset: SQL injection vulnerability in adhoc clauses

> Authenticated users can bypass subquery restrictions to read unauthorized database tables via SQL injection in Apache Superset.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2023
- **Updated:** 8 Apr 2025
- **Also known as:** BIT-superset-2022-41703, GHSA-cxvp-3frm-3876, PYSEC-2026-780

## What is CVE-2022-41703?

CVE-2022-41703 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in the SQL Alchemy connector of Apache Superset allows an authenticated user with read access to a specific database to add subqueries to the WHERE and HAVING fields referencing tables on the same database that the user should not have access to, despite the user having the feature flag "ALLOW_ADHOC_SUBQUERY" disabled (default value).  This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-41703?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | None |
| `apache-superset` | PyPI | All versions | None |
| `apache-superset` | PyPI | All versions | 1.5.3, 2.0.1 |
| `apache-superset` | PyPI | All versions to 1.5.2 | None |
| `apache-superset` | PyPI | All versions to 1.5.2 | None |
| `superset` | Bitnami | All versions | 1.5.3, 2.0.1 |

Products: Apache Superset.

## How do I fix CVE-2022-41703?

Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.

## Is CVE-2022-41703 being exploited?

There is no known exploitation of CVE-2022-41703 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41703 and fix it if it is affected.

What it is: CVE-2022-41703 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41703 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; no fix listed
- apache-superset (PyPI): affected all versions; no fix listed
- apache-superset (PyPI): affected all versions; fixed in 1.5.3, 2.0.1
- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed
- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed
- superset (Bitnami): affected all versions; fixed in 1.5.3, 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41703/ (Markdown: https://insights.sbomify.com/CVE-2022-41703/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41703
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41703
- OSV: https://osv.dev/vulnerability/CVE-2022-41703

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41703/
Summaries are generated and may contain mistakes; the official description above is the record.
