# CVE-2022-41706: Browsershot 3.57.2 - Server Side XSS to LFR via URL

> An attacker can read arbitrary local files by manipulating the URL protocol in Browsershot, leading to information disclosure.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2022
- **Updated:** 3 Dec 2025
- **Also known as:** GHSA-8c2c-jxwj-jqgf

## What is CVE-2022-41706?

CVE-2022-41706 is a high-severity server-side request forgery vulnerability in Browsershot, published on 25 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Browsershot version 3.57.2 allows an external attacker to remotely obtain arbitrary local files. This is possible because the application does not validate the URL protocol passed to the Browsershot::url method.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-41706?

2 open source packages ship an affected version, including spatie/browsershot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spatie/browsershot` | Packagist | All versions | 3.57.3 |
| `spatie/browsershot` | Packagist | All versions | 3.57.3 |

Products: Spatie Browsershot.

## How do I fix CVE-2022-41706?

Upgrade spatie/browsershot to 3.57.3 or later.

## Is CVE-2022-41706 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41706 exists.

## Other vulnerabilities in Browsershot

- [CVE-2022-43983](https://insights.sbomify.com/CVE-2022-43983/): Browsershot 3.57.2 - Server Side XSS to LFR via HTML (high 8.2)
- [CVE-2022-43984](https://insights.sbomify.com/CVE-2022-43984/): Browsershot 3.57.3 - Server Side XSS to LFR via HTML (high 8.2)
- [CVE-2020-7790](https://insights.sbomify.com/CVE-2020-7790/): Arbitrary File Read (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41706 and fix it if it is affected.

What it is: CVE-2022-41706 is a high-severity server-side request forgery vulnerability in Browsershot, published on 25 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41706 exists.

Affected packages and fixed versions:
- spatie/browsershot (Packagist): affected all versions; fixed in 3.57.3
- spatie/browsershot (Packagist): affected all versions; fixed in 3.57.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41706/ (Markdown: https://insights.sbomify.com/CVE-2022-41706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41706
- OSV: https://osv.dev/vulnerability/CVE-2022-41706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41706/
Summaries are generated and may contain mistakes; the official description above is the record.
