# CVE-2022-41711: Badaso vulnerable to Remote Code Execution via malicious file upload

> Unauthenticated attackers can execute arbitrary code on Badaso servers due to improper validation of uploaded files.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-fwvc-9xhj-26v5

## What is CVE-2022-41711?

CVE-2022-41711 is a critical vulnerability in Badaso, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Badaso version 2.6.0 allows an unauthenticated remote attacker to execute arbitrary code remotely on the server. This is possible because the application does not properly validate the data uploaded by users.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-41711?

2 open source packages ship an affected version, including badaso/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `badaso/core` | Packagist | All versions | 2.6.1 |
| `badaso/core` | Packagist | All versions | 2.6.1 |

Products: Uatech Badaso.

## How do I fix CVE-2022-41711?

Upgrade badaso/core to 2.6.1 or later.

## Is CVE-2022-41711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41711 exists.

## Other vulnerabilities in Badaso

- [CVE-2025-52353](https://insights.sbomify.com/CVE-2025-52353/): Badaso CMS file upload vulnerability (critical 9.8)
- [CVE-2022-41705](https://insights.sbomify.com/CVE-2022-41705/): Badaso vulnerable to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2025-15398](https://insights.sbomify.com/CVE-2025-15398/): Uasoft badaso Token BadasoAuthController.php forgetPassword password recovery (medium 6.3)
- [CVE-2023-38970](https://insights.sbomify.com/CVE-2023-38970/): Badaso vulnerable to cross-site scripting (medium 5.4)
- [CVE-2023-38971](https://insights.sbomify.com/CVE-2023-38971/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41711 and fix it if it is affected.

What it is: CVE-2022-41711 is a critical vulnerability in Badaso, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41711 exists.

Affected packages and fixed versions:
- badaso/core (Packagist): affected all versions; fixed in 2.6.1
- badaso/core (Packagist): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41711/ (Markdown: https://insights.sbomify.com/CVE-2022-41711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41711
- OSV: https://osv.dev/vulnerability/CVE-2022-41711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41711/
Summaries are generated and may contain mistakes; the official description above is the record.
