# CVE-2022-41713: deep-object-diff 1.1.0 - Prototype Pollution

> An attacker can modify object properties via prototype pollution in the deep-object-diff library due to insufficient JSON key validation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2022
- **Updated:** 3 Dec 2025
- **Also known as:** GHSA-653v-rqx9-j85p

## What is CVE-2022-41713?

CVE-2022-41713 is a medium-severity vulnerability in deep-object-diff, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

deep-object-diff version 1.1.0 allows an external attacker to edit or add new properties to an object. This is possible because the application does not properly validate incoming JSON keys, thus allowing the '__proto__' property to be edited.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-41713?

2 open source packages ship an affected version, including deep-object-diff. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deep-object-diff` | npm | From 1.1.6 | 1.1.9 |
| `deep-object-diff` | npm | From 1.1.6 | 1.1.9 |

Products: Deep-Object-Diff Project Deep-Object-Diff.

## How do I fix CVE-2022-41713?

Upgrade deep-object-diff to 1.1.9 or later.

## Is CVE-2022-41713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41713 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41713 and fix it if it is affected.

What it is: CVE-2022-41713 is a medium-severity vulnerability in deep-object-diff, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41713 exists.

Affected packages and fixed versions:
- deep-object-diff (npm): affected from 1.1.6; fixed in 1.1.9
- deep-object-diff (npm): affected from 1.1.6; fixed in 1.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41713/ (Markdown: https://insights.sbomify.com/CVE-2022-41713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41713
- OSV: https://osv.dev/vulnerability/CVE-2022-41713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41713/
Summaries are generated and may contain mistakes; the official description above is the record.
