# CVE-2022-41719: Panic in github.com/shamaton/msgpack/v2

> An attacker can cause a denial of service by sending crafted inputs to the msgpack unmarshal function in the Go library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-jr77-8gx4-h5qh, GO-2022-0972

## What is CVE-2022-41719?

CVE-2022-41719 is a high-severity denial of service vulnerability in github.com/shamaton/msgpack/v2, published on 10 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unmarshal can panic on some inputs, possibly allowing for denial of service attacks.

## Which versions are affected by CVE-2022-41719?

3 open source packages ship an affected version, including github.com/shamaton/msgpack/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/shamaton/msgpack/v2` | Go | All versions | 2.1.1 |
| `github.com/shamaton/msgpack/v2` | Go | All versions | 2.1.1 |
| `github.com/shamaton/msgpack/v2` | Go | All versions | 2.1.1 |

Products: Messagepack Project Messagepack.

## How do I fix CVE-2022-41719?

Upgrade github.com/shamaton/msgpack/v2 to 2.1.1 or later.

## Is CVE-2022-41719 being exploited?

There is no known exploitation of CVE-2022-41719 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41719 and fix it if it is affected.

What it is: CVE-2022-41719 is a high-severity denial of service vulnerability in github.com/shamaton/msgpack/v2, published on 10 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41719 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/shamaton/msgpack/v2 (Go): affected all versions; fixed in 2.1.1
- github.com/shamaton/msgpack/v2 (Go): affected all versions; fixed in 2.1.1
- github.com/shamaton/msgpack/v2 (Go): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41719/ (Markdown: https://insights.sbomify.com/CVE-2022-41719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41719
- OSV: https://osv.dev/vulnerability/CVE-2022-41719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41719/
Summaries are generated and may contain mistakes; the official description above is the record.
