CVE-2022-41741 NGINX ngx_http_mp4_module vulnerability CVE-2022-41741

High 7.0 Published Updated

A local attacker can corrupt NGINX worker memory via a crafted media file, causing termination or potential code execution in servers using the mp4 module.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41741?

CVE-2022-41741 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.

Weakness: CWE-787

Which versions are affected by CVE-2022-41741?

2 open source packages ship an affected version, including nginx and nginx-ingress-controller. It affects 4 products.

PackageAffectedFixed in
nginx BitnamiFrom 1.1.31.22.1, 1.23.2
nginx-ingress-controller BitnamiFrom 1.9.01.12.4, 2.4.0
Linux distribution packages (1)
nginx openSUSE:TumbleweedAll versions1.23.2-1.1

Products include Debian Debian Linux, F5 Nginx, F5 Nginx Ingress Controller, Fedoraproject Fedora.

How do I fix CVE-2022-41741?

Upgrade nginx to a fixed version for your release line: 1.22.1 or 1.23.2.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2022-41741 being exploited?

There is no known exploitation of CVE-2022-41741 in the wild and no public exploit code.

Public exploit code: 2 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2022-41741, AZL-11320, BIT-nginx-2022-41741, BIT-nginx-ingress-controller-2022-41741, CLEANSTART-2026-CD77382, DEBIAN-CVE-2022-41741 and 3 more.

Is CVE-2022-41741 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free