{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-ingress-controller. It affects 4 products.","exploited":"There is no known exploitation of CVE-2022-41741 in the wild and no public exploit code.","fix":"Upgrade nginx to a fixed version for your release line: 1.22.1 or 1.23.2.","what":"CVE-2022-41741 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41741 and fix it if it is affected.\n\nWhat it is: CVE-2022-41741 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41741 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 1.1.3; fixed in 1.22.1, 1.23.2\n- nginx-ingress-controller (Bitnami): affected from 1.9.0; fixed in 1.12.4, 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41741/ (Markdown: https://insights.sbomify.com/CVE-2022-41741/index.md)","id":"CVE-2022-41741","markdown":"https://insights.sbomify.com/CVE-2022-41741/index.md","name":"CVE-2022-41741","record":{"aliases":["ALPINE-CVE-2022-41741","AZL-11320","BIT-nginx-2022-41741","BIT-nginx-ingress-controller-2022-41741","CLEANSTART-2026-CD77382","DEBIAN-CVE-2022-41741","GHSA-3v5h-538g-pr7g","UBUNTU-CVE-2022-41741","openSUSE-SU-2024:12433-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"NGINX web server","requires_auth":"low_privilege","summary":"A local attacker can corrupt NGINX worker memory via a crafted media file, causing termination or potential code execution in servers using the mp4 module.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"nginx","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2024-04-26","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-04-26T17:18:52Z","kind":"github_poc","ref":"https://github.com/dumbbutt0/evilMP4","stars":1,"title":"Explore CVE-2022-41741 with the Evil MP4 repository. It offers educational PoCs,and documentation on securing nginx against MP4 file vulnerabilities. For legal, ethical security testing only."},{"date":"2025-05-07T23:26:48Z","kind":"github_poc","ref":"https://github.com/moften/CVE-2022-41741-742-Nginx-Vulnerability-Scanner","stars":1,"title":"CVE-2022-41741/742 Nginx Vulnerability Scanner"}],"tier":"poc_unverified"},"has_fix":true,"headline":"NGINX ngx_http_mp4_module vulnerability CVE-2022-41741","id":"CVE-2022-41741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":7,"next":{"headline":"NGINX ngx_http_mp4_module vulnerability CVE-2022-41742","id":"CVE-2022-41742"},"packages":[{"ecosystem":"Bitnami","fixed":["1.22.1","1.23.2"],"introduced":["1.1.3","1.23.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2022-41741"},{"ecosystem":"Bitnami","fixed":["1.12.4","2.4.0"],"introduced":["1.9.0","2.0.0"],"last_affected":[],"package":"nginx-ingress-controller","purl":"pkg:bitnami/nginx-ingress-controller","source":"BIT-nginx-ingress-controller-2022-41741"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.23.2-1.1"],"introduced":["0"],"last_affected":[],"package":"nginx","purl":"pkg:rpm/opensuse/nginx\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12433-1"}],"prev":{"headline":"IBM Robotic Process Automation information disclosure","id":"CVE-2022-41740"},"products":["NGINX","NGINX Open Source Subscription","NGINX Plus"],"published":"2022-10-19","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-08","vendors":["F5"]},"summary":"A local attacker can corrupt NGINX worker memory via a crafted media file, causing termination or potential code execution in servers using the mp4 module.","url":"https://insights.sbomify.com/CVE-2022-41741/"}