CVE-2022-41742 NGINX ngx_http_mp4_module vulnerability CVE-2022-41742

High 7.1 Published Updated

A local attacker can crash the worker process or disclose memory by uploading a crafted media file to an NGINX server using the mp4 module.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41742?

CVE-2022-41742 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.

Weakness: CWE-787

Which versions are affected by CVE-2022-41742?

2 open source packages ship an affected version, including nginx and nginx-ingress-controller. It affects 4 products.

PackageAffectedFixed in
nginx BitnamiFrom 1.1.31.22.1, 1.23.2
nginx-ingress-controller BitnamiFrom 1.9.01.12.4, 2.4.0

Products include Debian Debian Linux, F5 Nginx, F5 Nginx Ingress Controller, Fedoraproject Fedora.

How do I fix CVE-2022-41742?

Upgrade nginx to a fixed version for your release line: 1.22.1 or 1.23.2.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2022-41742 being exploited?

There is no known exploitation of CVE-2022-41742 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2022-41742, AZL-11321, BIT-nginx-2022-41742, BIT-nginx-ingress-controller-2022-41742, CLEANSTART-2026-CN38977, DEBIAN-CVE-2022-41742 and 2 more.

Is CVE-2022-41742 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free