# CVE-2022-41742: NGINX ngx_http_mp4_module vulnerability CVE-2022-41742

> A local attacker can crash the worker process or disclose memory by uploading a crafted media file to an NGINX server using the mp4 module.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** ALPINE-CVE-2022-41742, AZL-11321, BIT-nginx-2022-41742, BIT-nginx-ingress-controller-2022-41742, CLEANSTART-2026-CN38977, DEBIAN-CVE-2022-41742, GHSA-wj45-j4gh-fm3x, UBUNTU-CVE-2022-41742

## What is CVE-2022-41742?

CVE-2022-41742 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-41742?

2 open source packages ship an affected version, including nginx and nginx-ingress-controller. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.1.3 | 1.22.1, 1.23.2 |
| `nginx-ingress-controller` | Bitnami | From 1.9.0 | 1.12.4, 2.4.0 |

Products: Debian Debian Linux, F5 Nginx, F5 Nginx Ingress Controller, Fedoraproject Fedora.

## How do I fix CVE-2022-41742?

Upgrade nginx to a fixed version for your release line: 1.22.1 or 1.23.2.

## Is CVE-2022-41742 being exploited?

There is no known exploitation of CVE-2022-41742 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41742 and fix it if it is affected.

What it is: CVE-2022-41742 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41742 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.1.3; fixed in 1.22.1, 1.23.2
- nginx-ingress-controller (Bitnami): affected from 1.9.0; fixed in 1.12.4, 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41742/ (Markdown: https://insights.sbomify.com/CVE-2022-41742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41742
- OSV: https://osv.dev/vulnerability/CVE-2022-41742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41742/
Summaries are generated and may contain mistakes; the official description above is the record.
