# CVE-2022-41777: nadesiko3 allows remote attacker to inject invalid value to decodeURIComponent of nako3edit

> A remote attacker can crash the Nako3edit server by injecting invalid values into decodeURIComponent, affecting the Nadesiko3 PC editor.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-x2jx-w3wm-9p3p

## What is CVE-2022-41777?

CVE-2022-41777 is a high-severity denial of service vulnerability in kujirahand Nako3edit, editor component of nadesiko3 (PC Version), published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper check or handling of exceptional conditions vulnerability in Nako3edit, editor component of nadesiko3 (PC Version) v3.3.74 and earlier allows a remote attacker to inject an invalid value to decodeURIComponent of nako3edit, which may lead the server to crash.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-41777?

2 open source packages ship an affected version, including nadesiko3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nadesiko3` | npm | All versions | 3.3.75 |
| `nadesiko3` | npm | All versions | 3.3.75 |

Products: Kujirahand Nadesiko3.

## How do I fix CVE-2022-41777?

Upgrade nadesiko3 to 3.3.75 or later.

## Is CVE-2022-41777 being exploited?

There is no known exploitation of CVE-2022-41777 in the wild and no public exploit code.

## Other vulnerabilities in kujirahand Nako3edit, editor component of nadesiko3 (PC Version)

- [CVE-2022-41642](https://insights.sbomify.com/CVE-2022-41642/): Nadesiko3 OS Command Injection vulnerability (critical 9.8)
- [CVE-2022-42496](https://insights.sbomify.com/CVE-2022-42496/): nadesiko3 vulnerable to OS Command Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41777 and fix it if it is affected.

What it is: CVE-2022-41777 is a high-severity denial of service vulnerability in kujirahand Nako3edit, editor component of nadesiko3 (PC Version), published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41777 in the wild and no public exploit code.

Affected packages and fixed versions:
- nadesiko3 (npm): affected all versions; fixed in 3.3.75
- nadesiko3 (npm): affected all versions; fixed in 3.3.75

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41777/ (Markdown: https://insights.sbomify.com/CVE-2022-41777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41777
- OSV: https://osv.dev/vulnerability/CVE-2022-41777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41777/
Summaries are generated and may contain mistakes; the official description above is the record.
