# CVE-2022-41874: Tauri Filesystem Scope can be Partially Bypassed

> Attackers can bypass filesystem scope restrictions to access neighboring files via malicious file selection in Tauri desktop applications.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-q9wv-22m9-vhqh, RUSTSEC-2022-0091

## What is CVE-2022-41874?

CVE-2022-41874 is a low-severity path traversal vulnerability in tauri-apps tauri, published on 10 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Tauri is a framework for building binaries for all major desktop platforms. In versions prior to 1.0.7 and 1.1.2, Tauri is vulnerable to an Incorrectly-Resolved Name. Due to incorrect escaping of special characters in paths selected via the file dialog and drag and drop functionality, it is possible to partially bypass the `fs` scope definition. It is not possible to traverse into arbitrary paths, as the issue is limited to neighboring files and sub folders of already allowed paths. The impact differs on Windows, MacOS and Linux due to different specifications of valid path characters. This bypass depends on the file picker dialog or dragged files, as user selected paths are automatically added to the allow list at runtime. A successful bypass requires the user to select a pre-existing malicious file or directory during the file picker dialog and an adversary controlled logic to access these files. The issue has been patched in versions 1.0.7, 1.1.2 and 1.2.0. As a workaround, disable the dialog and fileDropEnabled component inside the tauri.conf.json.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-41874?

5 open source packages ship an affected version, including Tauri and tauri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Tauri` | crates.io | From 1.0.0 | 1.0.7 |
| `Tauri` | crates.io | From 1.0.0 | 1.0.7 |
| `Tauri` | crates.io | From 1.1.0 | 1.1.2 |
| `Tauri` | crates.io | From 1.1.0 | 1.1.2 |
| `tauri` | crates.io | From 1.0.0 | 1.0.7, 1.1.2 |

Products: Tauri Tauri.

## How do I fix CVE-2022-41874?

Upgrade Tauri to a fixed version for your release line: 1.0.7 or 1.1.2.

## Is CVE-2022-41874 being exploited?

There is no known exploitation of CVE-2022-41874 in the wild and no public exploit code.

## Other vulnerabilities in tauri-apps tauri

- [CVE-2023-46115](https://insights.sbomify.com/CVE-2023-46115/): Updater Private Keys Possibly Leaked via Vite Environment Variables in tauri-cli (high 8.4)
- [CVE-2022-39215](https://insights.sbomify.com/CVE-2022-39215/): The readDir Endpoint Scope can be Bypassed With Symbolic Links in Tauri (high 8.3)
- [CVE-2022-46171](https://insights.sbomify.com/CVE-2022-46171/): Tauri vulnerable to path traversal (medium 6.8)
- [CVE-2026-42184](https://insights.sbomify.com/CVE-2026-42184/): Tauri: Origin Confusion Allows Remote Pages to Invoke Local-Only IPC Commands (medium 6.1)
- [CVE-2023-34460](https://insights.sbomify.com/CVE-2023-34460/): Tauri vulnerable to Regression on Filesystem Scope Checks for Dotfiles (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41874 and fix it if it is affected.

What it is: CVE-2022-41874 is a low-severity path traversal vulnerability in tauri-apps tauri, published on 10 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41874 in the wild and no public exploit code.

Affected packages and fixed versions:
- Tauri (crates.io): affected from 1.0.0; fixed in 1.0.7
- Tauri (crates.io): affected from 1.0.0; fixed in 1.0.7
- Tauri (crates.io): affected from 1.1.0; fixed in 1.1.2
- Tauri (crates.io): affected from 1.1.0; fixed in 1.1.2
- tauri (crates.io): affected from 1.0.0; fixed in 1.0.7, 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41874/ (Markdown: https://insights.sbomify.com/CVE-2022-41874/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41874
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41874
- OSV: https://osv.dev/vulnerability/CVE-2022-41874

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41874/
Summaries are generated and may contain mistakes; the official description above is the record.
