CVE-2022-41878 Parse Server Prototype pollution and Injection via Cloud Code Webhooks or Cloud Code Triggers
Attackers can inject keywords via Cloud Code Webhooks or Triggers, bypassing requestKeywordDenylist and modifying database entries.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41878?
CVE-2022-41878 is a high-severity code injection vulnerability in Parseplatform Parse-Server, published on 10 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 5.3.2 or 4.10.19, keywords that are specified in the Parse Server option `requestKeywordDenylist` can be injected via Cloud Code Webhooks or Triggers. This will result in the keyword being saved to the database, bypassing the `requestKeywordDenylist` option. This issue is fixed in versions 4.10.19, and 5.3.2. If upgrade is not possible, the following Workarounds may be applied: Configure your firewall to only allow trusted servers to make request to the Parse Server Cloud Code Webhooks API, or block the API completely if you are not using the feature.
Which versions are affected by CVE-2022-41878?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 4.10.19 |
parse-server npm | All versions | 4.10.19 |
parse-server npm | From 5.0.0 | 5.3.2 |
parse-server npm | From 5.0.0 | 5.3.2 |
parse Bitnami | All versions | 4.10.19, 5.3.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2022-41878?
Upgrade parse-server to a fixed version for your release line: 4.10.19 or 5.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-41878 being exploited?
There is no known exploitation of CVE-2022-41878 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2022-41878, GHSA-xprv-wvh7-qqqx.