# CVE-2022-41879: Parse Server subject to Prototype pollution via Cloud Code Webhooks

> Attackers can bypass security restrictions via prototype pollution in Cloud Code Webhooks, requiring an upgrade to patched versions.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-parse-2022-41879, GHSA-93vw-8fm5-p2jf

## What is CVE-2022-41879?

CVE-2022-41879 is a high-severity code injection vulnerability in Parseplatform Parse-Server, published on 10 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 5.3.3 or 4.10.20, a compromised Parse Server Cloud Code Webhook target endpoint allows an attacker to use prototype pollution to bypass the Parse Server `requestKeywordDenylist` option. This issue has been patched in versions 5.3.3 and 4.10.20. There are no known workarounds.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-41879?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.20 |
| `parse-server` | npm | All versions | 4.10.20 |
| `parse-server` | npm | From 5.0.0 | 5.3.3 |
| `parse-server` | npm | From 5.0.0 | 5.3.3 |
| `parse` | Bitnami | All versions | 4.10.20, 5.3.3 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-41879?

Upgrade parse-server to a fixed version for your release line: 4.10.20 or 5.3.3.

## Is CVE-2022-41879 being exploited?

There is no known exploitation of CVE-2022-41879 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41879 and fix it if it is affected.

What it is: CVE-2022-41879 is a high-severity code injection vulnerability in Parseplatform Parse-Server, published on 10 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41879 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.20
- parse-server (npm): affected all versions; fixed in 4.10.20
- parse-server (npm): affected from 5.0.0; fixed in 5.3.3
- parse-server (npm): affected from 5.0.0; fixed in 5.3.3
- parse (Bitnami): affected all versions; fixed in 4.10.20, 5.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41879/ (Markdown: https://insights.sbomify.com/CVE-2022-41879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41879
- OSV: https://osv.dev/vulnerability/CVE-2022-41879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41879/
Summaries are generated and may contain mistakes; the official description above is the record.
