{"answers":{"affected":"2 open source packages ship an affected version, including io.netty:netty-codec-haproxy. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41881 exists.","fix":"Upgrade io.netty:netty-codec-haproxy to 4.1.86.Final or later.","what":"CVE-2022-41881 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41881 and fix it if it is affected.\n\nWhat it is: CVE-2022-41881 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41881 exists.\n\nAffected packages and fixed versions:\n- io.netty:netty-codec-haproxy (Maven): affected all versions; fixed in 4.1.86.Final\n- io.netty:netty-codec-haproxy (Maven): affected all versions; fixed in 4.1.86.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41881/ (Markdown: https://insights.sbomify.com/CVE-2022-41881/index.md)","id":"CVE-2022-41881","markdown":"https://insights.sbomify.com/CVE-2022-41881/index.md","name":"CVE-2022-41881","record":{"aliases":["CLEANSTART-2026-BT29481","CLEANSTART-2026-YG36157","DEBIAN-CVE-2022-41881","GHSA-fx2c-96vj-985v","MINI-jw43-5qv9-hjcg","OESA-2023-1905","OESA-2023-1906","OESA-2023-1907","OESA-2023-1999","OESA-2023-2000","OESA-2023-2001","UBUNTU-CVE-2022-41881"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Netty network framework","requires_auth":"none","summary":"Attackers can cause a denial of service via infinite recursion when parsing malformed messages in the Netty network framework.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"netty","vendor":"netty"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"HAProxyMessageDecoder Stack Exhaustion DoS","id":"CVE-2022-41881","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux","netty:netty"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Nextcloud Desktop vulnerable to code injection via malicious link","id":"CVE-2022-41882"},"packages":[{"ecosystem":"Maven","fixed":["4.1.86.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty:netty-codec-haproxy","purl":null,"source":"GHSA-fx2c-96vj-985v"},{"ecosystem":"Maven","fixed":["4.1.86.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty:netty-codec-haproxy","purl":"pkg:maven/io.netty/netty-codec-haproxy","source":"GHSA-fx2c-96vj-985v"}],"prev":{"headline":"ThreadUnsafeUnigramCandidateSampler Heap out of bounds in Tensorflow","id":"CVE-2022-41880"},"products":["netty"],"published":"2022-12-12","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["netty"]},"summary":"Attackers can cause a denial of service via infinite recursion when parsing malformed messages in the Netty network framework.","url":"https://insights.sbomify.com/CVE-2022-41881/"}