CVE-2022-41883 Out of bounds segmentation fault due to unequal op inputs in Tensorflow

Medium 6.8 Published Updated

An attacker can cause a segmentation fault and crash the application by providing unequal input sizes to TensorFlow operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-41883?

CVE-2022-41883 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 18 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TensorFlow is an open source platform for machine learning. When ops that have specified input sizes receive a differing number of inputs, the executor will crash. We have patched the issue in GitHub commit f5381e0e10b5a61344109c1b7c174c68110f7629. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Weakness: CWE-125

Which versions are affected by CVE-2022-41883?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiFrom 2.10.02.10.1
tensorflow PyPIFrom 2.10.02.10.1
tensorflow PyPIFrom 2.10.02.10.1
tensorflow PyPIFrom 2.10.02.10.1
tensorflow-cpu PyPIFrom 2.10.02.10.1
tensorflow-cpu PyPIFrom 2.10.02.10.1
4 more packages
tensorflow-cpu PyPIFrom 2.10.02.10.1
tensorflow-gpu PyPIFrom 2.10.02.10.1
tensorflow-gpu PyPIFrom 2.10.02.10.1
tensorflow-gpu PyPIFrom 2.10.02.10.1

Products include Google Tensorflow.

How do I fix CVE-2022-41883?

Upgrade tensorflow to 2.10.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-41883 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41883 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-41883, GHSA-w58w-79xv-6vcj, PYSEC-2026-1042, PYSEC-2026-3251, PYSEC-2026-3376.

Is CVE-2022-41883 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free