# CVE-2022-41883: Out of bounds segmentation fault due to unequal op inputs in Tensorflow

> An attacker can cause a segmentation fault and crash the application by providing unequal input sizes to TensorFlow operations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-tensorflow-2022-41883, GHSA-w58w-79xv-6vcj, PYSEC-2026-1042, PYSEC-2026-3251, PYSEC-2026-3376

## What is CVE-2022-41883?

CVE-2022-41883 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 18 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

TensorFlow is an open source platform for machine learning. When ops that have specified input sizes receive a differing number of inputs, the executor will crash. We have patched the issue in GitHub commit f5381e0e10b5a61344109c1b7c174c68110f7629. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-41883?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | From 2.10.0 | 2.10.1 |
| `tensorflow` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-cpu` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-cpu` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-cpu` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-gpu` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-gpu` | PyPI | From 2.10.0 | 2.10.1 |
| `tensorflow-gpu` | PyPI | From 2.10.0 | 2.10.1 |

Products: Google Tensorflow.

## How do I fix CVE-2022-41883?

Upgrade tensorflow to 2.10.1 or later.

## Is CVE-2022-41883 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41883 exists.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41883 and fix it if it is affected.

What it is: CVE-2022-41883 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 18 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41883 exists.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected from 2.10.0; fixed in 2.10.1
- tensorflow (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-cpu (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-cpu (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-cpu (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-gpu (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-gpu (PyPI): affected from 2.10.0; fixed in 2.10.1
- tensorflow-gpu (PyPI): affected from 2.10.0; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41883/ (Markdown: https://insights.sbomify.com/CVE-2022-41883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41883
- OSV: https://osv.dev/vulnerability/CVE-2022-41883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41883/
Summaries are generated and may contain mistakes; the official description above is the record.
