CVE-2022-41887 Overflow in `tf.keras.losses.poisson` in Tensorflow
An integer overflow in TensorFlow's Poisson loss function causes a crash when processing specific inputs, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-41887?
CVE-2022-41887 is a medium-severity vulnerability in Google Tensorflow, published on 18 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TensorFlow is an open source platform for machine learning. `tf.keras.losses.poisson` receives a `y_pred` and `y_true` that are passed through `functor::mul` in `BinaryOp`. If the resulting dimensions overflow an `int32`, TensorFlow will crash due to a size mismatch during broadcast assignment. We have patched the issue in GitHub commit c5b30379ba87cbe774b08ac50c1f6d36df4ebb7c. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1 and 2.9.3, as these are also affected and still in supported range. However, we will not cherrypick this commit into TensorFlow 2.8.x, as it depends on Eigen behavior that changed between 2.8 and 2.9.
Weakness: CWE-131
Which versions are affected by CVE-2022-41887?
16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | From 2.9.0 | 2.9.3, 2.10.1 |
tensorflow PyPI | All versions | 2.9.3, 2.10.1 |
tensorflow PyPI | All versions | 2.9.3 |
tensorflow PyPI | All versions | 2.9.3 |
tensorflow PyPI | From 2.10.0 | 2.10.1 |
tensorflow PyPI | From 2.10.0 | 2.10.1 |
10 more packages
tensorflow-cpu PyPI | All versions | 2.9.3, 2.10.1 |
tensorflow-cpu PyPI | All versions | 2.9.3 |
tensorflow-cpu PyPI | All versions | 2.9.3 |
tensorflow-cpu PyPI | From 2.10.0 | 2.10.1 |
tensorflow-cpu PyPI | From 2.10.0 | 2.10.1 |
tensorflow-gpu PyPI | All versions | 2.9.3, 2.10.1 |
tensorflow-gpu PyPI | All versions | 2.9.3 |
tensorflow-gpu PyPI | All versions | 2.9.3 |
tensorflow-gpu PyPI | From 2.10.0 | 2.10.1 |
tensorflow-gpu PyPI | From 2.10.0 | 2.10.1 |
Products include Google Tensorflow.
How do I fix CVE-2022-41887?
Upgrade tensorflow to a fixed version for your release line: 2.9.3 or 2.10.1.
Is CVE-2022-41887 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41887 exists.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2022-41887, GHSA-8fvv-46hw-vpg3, PYSEC-2026-3136, PYSEC-2026-3297, PYSEC-2026-970.