CVE-2022-41892 Arches vulnerable to SQL Injection
Attackers can execute arbitrary SQL statements via crafted web requests, potentially reading or modifying database contents in Arches.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41892?
CVE-2022-41892 is a high-severity SQL injection vulnerability in archesproject arches, published on 11 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.
Weakness: CWE-89
Which versions are affected by CVE-2022-41892?
7 open source packages ship an affected version, including arches. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
arches PyPI | All versions | 6.1.2 |
arches PyPI | All versions | 6.1.2 |
arches PyPI | All versions | 6.1.2 |
arches PyPI | From 6.2.0 | 6.2.1 |
arches PyPI | From 6.2.0 | 6.2.1 |
arches PyPI | From 7.0.0 | 7.2.0 |
1 more packages
arches PyPI | From 7.0.0 | 7.2.0 |
Products include Archesproject Arches.
How do I fix CVE-2022-41892?
Upgrade arches to a fixed version for your release line: 6.1.2, 6.2.1 or 7.2.0.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2022-41892 being exploited?
There is no known exploitation of CVE-2022-41892 in the wild and no public exploit code.
Sources
Also known as GHSA-gmpq-xrxj-xh8m, PYSEC-2022-42985.