{"answers":{"affected":"3 open source packages ship an affected version, including wsgidav. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41905 in the wild and no public exploit code.","fix":"Upgrade wsgidav to 4.1.0 or later.","what":"CVE-2022-41905 is a high-severity cross-site scripting vulnerability in mar10 wsgidav, published on 11 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-41905 and fix it if it is affected.\n\nWhat it is: CVE-2022-41905 is a high-severity cross-site scripting vulnerability in mar10 wsgidav, published on 11 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-41905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wsgidav (PyPI): affected from 3.0.0; fixed in 4.1.0\n- wsgidav (PyPI): affected from 3.0.0a1; fixed in 4.1.0\n- wsgidav (PyPI): affected from 3.0.0a1; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41905/ (Markdown: https://insights.sbomify.com/CVE-2022-41905/index.md)","id":"CVE-2022-41905","markdown":"https://insights.sbomify.com/CVE-2022-41905/index.md","name":"CVE-2022-41905","record":{"aliases":["GHSA-xx6g-jj35-pxjv","PYSEC-2022-43018"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"WebDAV server library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in user browsers via XSS in WsgiDAV when directory browsing is enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wsgidav","vendor":"wsgidav_project"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled","id":"CVE-2022-41905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"OpenSearch Notifications is vulnerable to Server-Side Request Forgery (SSRF)","id":"CVE-2022-41906"},"packages":[{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"wsgidav","purl":"pkg:pypi/wsgidav","source":"PYSEC-2022-43018"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["3.0.0a1"],"last_affected":[],"package":"wsgidav","purl":null,"source":"GHSA-xx6g-jj35-pxjv"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["3.0.0a1"],"last_affected":[],"package":"wsgidav","purl":"pkg:pypi/wsgidav","source":"GHSA-xx6g-jj35-pxjv"}],"prev":{"headline":"Element iOS is vulnerable due to missing decoration for events decrypted with untrusted Megolm sessions","id":"CVE-2022-41904"},"products":["wsgidav"],"published":"2022-11-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["mar10"]},"summary":"Attackers can execute arbitrary scripts in user browsers via XSS in WsgiDAV when directory browsing is enabled.","url":"https://insights.sbomify.com/CVE-2022-41905/"}